Use p_new instead of xmalloc()
[apps/madmutt.git] / contrib / muttng.spec
1 Summary: A text mode mail user agent.
2 Name: muttng
3 Version: 20050718
4 Release: 3
5 Serial: 1
6 License: GPL
7 Group: Applications/Internet
8 Source: http://nion.modprobe.de/mutt-ng/snapshots/%{name}-%{version}.tar.gz
9 Url: http://www.muttng.org/
10 Requires: slang >= 0.99.38, smtpdaemon, webclient, mailcap, gettext
11 Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
12 %{!?nossl:BuildPrereq: openssl-devel}
13 %{!?nokerberos:BuildPrereq: krb5-devel}
14 BuildPrereq: /usr/sbin/sendmail slang-devel /usr/bin/automake-1.4
15
16 %description
17 Mutt-ng is a text-mode mail user agent. Mutt supports color, threading,
18 arbitrary key remapping, and a lot of customization.
19
20 You should install mutt if you have used it in the past and you prefer
21 it, or if you are new to mail programs and have not decided which one
22 you are going to use.
23
24 %prep
25 %setup -n %{name}-%{version} -q
26
27 %build
28 rm -rf autom4te.cache
29 ./autogen.sh
30 chmod 700 ./configure
31 export -n LINGUAS
32 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix} \
33         --with-sharedir=/etc --sysconfdir=/etc \
34         --with-docdir=%{_docdir}/mutt-%{version} \
35         --with-mandir=%{_mandir} \
36         --with-infodir=%{_infodir} \
37         --enable-pop --enable-imap \
38         --with-sasl \
39 %{!?nossl:--with-ssl} \
40 %{!?nokerberos:--with-gss=/usr/kerberos} \
41         --disable-warnings --with-slang --disable-domain \
42         --disable-flock --enable-fcntl \
43         --enable-buffy-size
44 make
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 %makeinstall sharedir=$RPM_BUILD_ROOT/etc \
49   sysconfdir=$RPM_BUILD_ROOT/etc \
50   docdir=$RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} \
51   install
52 mkdir -p $RPM_BUILD_ROOT/etc/X11/applnk/Internet
53
54 # we like GPG here
55 cat contrib/gpg.rc >> \
56         $RPM_BUILD_ROOT/etc/Muttngrc
57 grep -5 "^color" contrib/sample.muttrc >> \
58         $RPM_BUILD_ROOT/etc/Muttngrc
59 # and we use aspell
60
61 cat >> $RPM_BUILD_ROOT/etc/Muttngrc <<EOF
62 # use aspell
63 set ispell="/usr/bin/aspell --mode=email check"
64
65 EOF
66
67 %find_lang %{name}
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files -f %{name}.lang
73 %defattr(-,root,root)
74 %config /etc/Muttngrc
75 %config /etc/muttng-mime.types
76 %doc ABOUT-NLS ChangeLog* COPYRIGHT GPL INSTALL NEWS README* TODO* UPGRADING 
77 %doc doc/applying-patches.txt doc/*-notes.txt doc/PGP-Notes.txt doc/manual* contrib/* 
78 %{_bindir}/muttng
79 %{_bindir}/muttngbug
80 %attr(2755,root,mail) %{_bindir}/muttng_dotlock
81 %{_bindir}/fleang
82 %{_bindir}/pgpringng
83 %{_bindir}/pgpewrapng
84 %{_bindir}/smime_keysng
85 %{_mandir}/man1/muttng.*
86 %{_mandir}/man1/muttngbug.*
87 %{_mandir}/man1/muttng_dotlock.*
88 %{_mandir}/man1/muttng-flea.*
89 %{_mandir}/man1/fleang.*
90 %{_mandir}/man5/muttngrc.*
91 %{_mandir}/man5/muttng-mbox.*
92
93 %changelog
94 * Mon Jul 18 2005 Iain Lea <iain@bricbrac.de>  1:20050718-3
95 - fixed to use ./autogen.sh instead of ./prepare script
96 * Mon Mar 14 2005 Iain Lea <iain@bricbrac.de>  1:20050314-2
97 - fixed aclocal/automake/autoconf/prepare weirdness (rm -rf autom4te.cache)
98 * Sun Mar 06 2005 Iain Lea <iain@bricbrac.de>  1:20050306-1
99 - initial muttng.spec file