drop GSS as well, users will have to use correctly configured sasl.
[apps/madmutt.git] / imap / Makefile.am
index 4dbf7db..0009dc5 100644 (file)
@@ -1,27 +1,11 @@
-## Process this file with automake to produce Makefile.in
-
-AR=@AR@
-
-AUTOMAKE_OPTIONS = foreign
-
-if USE_GSS
-GSSSOURCES = auth_gss.c
-endif
-
-if USE_SASL
-AUTHENTICATORS = auth_sasl.c
-else
-AUTHENTICATORS = auth_anon.c auth_cram.c
-endif
-
-EXTRA_DIST = BUGS README TODO auth_anon.c auth_cram.c auth_gss.c auth_sasl.c
+EXTRA_DIST = BUGS README TODO
 
 INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/intl
 
 noinst_LIBRARIES = libimap.a
-noinst_HEADERS = auth.h imap_private.h message.h mx_imap.h
+noinst_HEADERS = auth.h imap_private.h message.h
 
-libimap_a_SOURCES = auth.c auth_login.c browse.c command.c imap.c imap.h mx_imap.h \
-       message.c utf7.c util.c mx_imap.c $(AUTHENTICATORS) $(GSSSOURCES)
+libimap_a_SOURCES = auth.c auth_login.c browse.c command.c imap.c imap.h \
+       message.c utf7.c util.c auth_sasl.c
 
--include ../cflags.mk
+-include $(top_builddir)/tools/cflags.mk