update source to use our brand new source generator. Update automakes.
[apps/madmutt.git] / lib-lib / Makefile.am
index 2b844c1..3346eeb 100644 (file)
@@ -1,7 +1,10 @@
 noinst_LIBRARIES = liblib.a
 
-liblib_a_SOURCES = mem.h str.h ascii.h buffer.h                              \
-                         str.c ascii.c buffer.c
+liblib_a_SOURCES = lib-lib.h mem.h \
+                  str.h utf8.h buffer.h hash.h array.h list.h file.h mapping.h date.h rx.h url.h \
+                   str.c utf8.c buffer.c hash.c array.c list.c file.c mapping.c date.c rx.c url.c
 
-noinst_HEADERS = mem.h str.h ascii.h
+noinst_HEADERS   = lib-lib.h mem.h \
+                  str.h utf8.h buffer.h hash.h array.h list.h file.h mapping.h date.h rx.h url.h
 
+-include $(top_builddir)/tools/cflags.mk