update source to use our brand new source generator. Update automakes.
[apps/madmutt.git] / lib-lib / Makefile.am
index d605e34..3346eeb 100644 (file)
@@ -1,14 +1,10 @@
 noinst_LIBRARIES = liblib.a
 
-liblib_a_SOURCES = lib-lib.h mem.h macros.h \
-                  str.h ascii.h buffer.h hash.h list.h file.h mapping.h \
-                   str.c ascii.c buffer.c hash.c list.c file.c mapping.c \
-                  \
-                  date.h rx.h url.h                                   \
-                  date.c rx.c url.c
+liblib_a_SOURCES = lib-lib.h mem.h \
+                  str.h utf8.h buffer.h hash.h array.h list.h file.h mapping.h date.h rx.h url.h \
+                   str.c utf8.c buffer.c hash.c array.c list.c file.c mapping.c date.c rx.c url.c
 
-noinst_HEADERS   = lib-lib.h mem.h macros.h \
-                  str.h ascii.h buffer.h hash.h list.h file.h mapping.h \
-                  date.h rx.h url.h
+noinst_HEADERS   = lib-lib.h mem.h \
+                  str.h utf8.h buffer.h hash.h array.h list.h file.h mapping.h date.h rx.h url.h
 
--include ../cflags.mk
+-include $(top_builddir)/tools/cflags.mk