update source to use our brand new source generator. Update automakes.
[apps/madmutt.git] / lib-lua / Makefile.am
index 8f149f5..64b8e6c 100644 (file)
@@ -1,13 +1,10 @@
 BUILT_SOURCES    = lua-token.h lua-token.c
 DISTCLEANFILES   = $(BUILT_SOURCES)
 
-.cpkg.c: ; ./luapkg2c.pl -c $< > $@
-.cpkg.h: ; ./luapkg2c.pl -h $< > $@
-
 noinst_LIBRARIES = liblua.a
 
-liblua_a_DEPENDENCIES = madmutt.h
-liblua_a_SOURCES = madmutt.cpkg \
+liblua_a_DEPENDENCIES = madmutt.li
+liblua_a_SOURCES = madmutt.c \
                   lib-lua.h \
                   runtime.c \
                   $(BUILT_SOURCES)
@@ -21,4 +18,5 @@ DEFS=-DPKGDATADIR=\"$(pkgdatadir)\" -DSYSCONFDIR=\"$(sysconfdir)\" \
        -DBINDIR=\"$(bindir)\" -DMUTTLOCALEDIR=\"$(datadir)/locale\" \
        -DHAVE_CONFIG_H=1 -DPKGDOCDIR=\"$(docdir)\"
 
--include ../cflags.mk
+include $(top_builddir)/tools/cpkg2c.mk
+-include $(top_builddir)/tools/cflags.mk