simplify alias expansion a lot.
[apps/madmutt.git] / lib-mime / Makefile.am
index b06f4f7..003aaf3 100644 (file)
@@ -1,8 +1,15 @@
+BUILT_SOURCES = mime-token.h mime-token.c
+CLEANFILES    = $(BUILT_SOURCES)
+
 noinst_LIBRARIES = libmime.a
 
-libmime_a_SOURCES = mime.h mime-types.h \
+libmime_a_SOURCES = mime.h mime-types.h $(BUILT_SOURCES) \
                    mime.c rfc822address.c rfc822parse.c rfc2047.c rfc2231.c
 
 noinst_HEADERS    = mime.h mime-types.h
 
+
+mime-token.c mime-token.h: mime-token.def mime-token.sh
+       sh mime-token.sh $@ < $<
+
 -include ../cflags.mk