simplify charset and things in the sockets API.
[apps/madmutt.git] / lib-mime / Makefile.am
index b7835fa..f8ecd2d 100644 (file)
@@ -1,7 +1,17 @@
+BUILT_SOURCES = mime-token.h mime-token.c
+DISTCLEANFILES    = $(BUILT_SOURCES)
+
 noinst_LIBRARIES = libmime.a
 
 noinst_LIBRARIES = libmime.a
 
-libmime_a_SOURCES = mime.h mime.c rfc822.c rfc2231.c
+libmime_a_SOURCES = mime.h mime-types.h $(BUILT_SOURCES) \
+                   mime.c rfc822address.c rfc822parse.c rfc1524.c rfc2047.c rfc2231.c \
+                   \
+                   rfc3676.h rfc3676.c
+
+noinst_HEADERS    = mime.h mime-types.h
+
 
 
-noinst_HEADERS    = mime.h
+mime-token.c mime-token.h: mime-token.def mime-token.sh
+       sh mime-token.sh $@ < $<
 
 -include ../cflags.mk
 
 -include ../cflags.mk