better debug symbols
[apps/madmutt.git] / lib-lua / Makefile.am
index b28c98d..64b8e6c 100644 (file)
@@ -1,18 +1,15 @@
 BUILT_SOURCES    = lua-token.h lua-token.c
 DISTCLEANFILES   = $(BUILT_SOURCES)
 
-.cpkg.c: ; ./luapkg2c.pl -c $< > $@
-.cpkg.h: ; ./luapkg2c.pl -h $< > $@
-
 noinst_LIBRARIES = liblua.a
 
-liblua_a_DEPENDENCIES = madmutt.h
-liblua_a_SOURCES = madmutt.cpkg \
-                  lib-lua.h lib-lua_priv.h \
+liblua_a_DEPENDENCIES = madmutt.li
+liblua_a_SOURCES = madmutt.c \
+                  lib-lua.h \
                   runtime.c \
                   $(BUILT_SOURCES)
 
-noinst_HEADERS   = lib-lua.h lib-lua_priv.h
+noinst_HEADERS   = lib-lua.h
 
 lua-token.c lua-token.h: lua-token.sh
        sh $< $@ || (rm -f $@; exit 1)
@@ -21,4 +18,5 @@ DEFS=-DPKGDATADIR=\"$(pkgdatadir)\" -DSYSCONFDIR=\"$(sysconfdir)\" \
        -DBINDIR=\"$(bindir)\" -DMUTTLOCALEDIR=\"$(datadir)/locale\" \
        -DHAVE_CONFIG_H=1 -DPKGDOCDIR=\"$(docdir)\"
 
--include ../cflags.mk
+include $(top_builddir)/tools/cpkg2c.mk
+-include $(top_builddir)/tools/cflags.mk