make luaM_checkquadopt accept some string arguments. ("yes", "no", "ask-yes", "ask...
[apps/madmutt.git] / lib-lua / Makefile.am
index 78006a1..a12888b 100644 (file)
@@ -1,13 +1,18 @@
 BUILT_SOURCES    = lua-token.h lua-token.c
 DISTCLEANFILES   = $(BUILT_SOURCES)
 
+.cpkg.c:  ; ./luapkg2c.pl -c $< > $@
+.cpkg.li: ; ./luapkg2c.pl -h $< > $@
+
 noinst_LIBRARIES = liblua.a
 
-liblua_a_SOURCES = lib-lua.h lib-lua_priv.h \
-                  runtime.c madmutt.c      \
+liblua_a_DEPENDENCIES = madmutt.li
+liblua_a_SOURCES = madmutt.cpkg \
+                  lib-lua.h \
+                  runtime.c \
                   $(BUILT_SOURCES)
 
-noinst_HEADERS   = lib-lua.h lib-lua_priv.h
+noinst_HEADERS   = lib-lua.h
 
 lua-token.c lua-token.h: lua-token.sh
        sh $< $@ || (rm -f $@; exit 1)