Don't force inetd_compat for upgrades.
authorPierre Habouzit <madcoder@debian.org>
Wed, 28 Nov 2007 10:54:27 +0000 (11:54 +0100)
committerPierre Habouzit <madcoder@debian.org>
Wed, 28 Nov 2007 10:54:27 +0000 (11:54 +0100)
Signed-off-by: Pierre Habouzit <madcoder@debian.org>
debian/NEWS
debian/changelog
debian/xinetd.postinst

index 374498e..8d24fd1 100644 (file)
@@ -2,9 +2,10 @@ xinetd (1:2.3.14-3) unstable; urgency=low
 
   This version enables inetd_compat mode by default, so that we can pretend to
   be a real inet-superserver. This way, packages that use update-inetd will
 
   This version enables inetd_compat mode by default, so that we can pretend to
   be a real inet-superserver. This way, packages that use update-inetd will
-  work with xinetd properly.
+  work with xinetd properly. The inetd_compat mode is forced for new
+  installations only, and can be tweaked in /etc/default/xinetd.
 
   Note that if the same service is configured in /etc/xinetd.d/ and in
 
   Note that if the same service is configured in /etc/xinetd.d/ and in
-  /etc/inetd.conf, the former takes precedence.
+  /etc/inetd.conf, the former takes precedence, based on the service id.
 
  -- Pierre Habouzit <madcoder@debian.org>  Tue, 27 Nov 2007 01:55:29 +0100
 
  -- Pierre Habouzit <madcoder@debian.org>  Tue, 27 Nov 2007 01:55:29 +0100
index 6bf0962..0f43d68 100644 (file)
@@ -8,6 +8,7 @@ xinetd (1:2.3.14-4) UNRELEASED; urgency=low
     debian/xinetd.defaults -> debian/xinetd.default.
   * debian/xinetd.postrm: don't purge configuration that isn't ours on purge
     anymore.
     debian/xinetd.defaults -> debian/xinetd.default.
   * debian/xinetd.postrm: don't purge configuration that isn't ours on purge
     anymore.
+  * Don't force inetd_compat for upgrades.
 
  -- Pierre Habouzit <madcoder@debian.org>  Wed, 28 Nov 2007 10:14:47 +0100
 
 
  -- Pierre Habouzit <madcoder@debian.org>  Wed, 28 Nov 2007 10:14:47 +0100
 
index 5281388..ac9fa57 100644 (file)
@@ -1,5 +1,11 @@
 #!/bin/sh -e
 
 #!/bin/sh -e
 
+if test "$1" = "configure"; then
+    if dpkg --compare-versions "$2" lt-nl 1:2.3.14-3; then
+        sed -e -i "s/INETD_COMPAT=Yes/INETD_COMPAT=No/" /etc/default/xinetd
+    fi
+fi
+
 if [ -x "`which invoke-rc.d 2>/dev/null`" ]; then
     invoke-rc.d xinetd stop
 elif [ -x /etc/init.d/xinetd ]; then
 if [ -x "`which invoke-rc.d 2>/dev/null`" ]; then
     invoke-rc.d xinetd stop
 elif [ -x /etc/init.d/xinetd ]; then