use the new flag by default
[packages/xinetd.git] / debian / rules
index f0e370e..25e856f 100755 (executable)
@@ -46,14 +46,14 @@ unpatch:
        rm -f patch-stamp
 
 configure: configure-stamp
-configure-stamp:
+configure-stamp: patch
        dh_testdir
-       chmod -R a=rX,u=rwX .
-       CFLAGS="-O2" ./configure --prefix=/usr             \
-              --mandir=\$${prefix}/share/man              \
-              --infodir=\$${prefix}/share/info            \
-              --host=$(DEB_HOST_GNU_TYPE)                 \
-              --build=$(DEB_BUILD_GNU_TYPE)               \
+       cp /usr/share/misc/config.* '$(CURDIR)'
+       CFLAGS="-O2" ./configure --prefix=/usr         \
+              --mandir=\$${prefix}/share/man          \
+              --infodir=\$${prefix}/share/info        \
+              --host=$(DEB_HOST_GNU_TYPE)             \
+              --build=$(DEB_BUILD_GNU_TYPE)           \
               \
               --with-loadavg          \
               --with-libwrap
@@ -77,7 +77,7 @@ install: build
        dh_testroot
        dh_clean -k
        dh_installdirs
-       $(MAKE) install prefix=$(pkgdir)
+       $(MAKE) install prefix=$(pkgdir)/usr
 
 binary-indep: build install
 
@@ -101,4 +101,4 @@ binary-arch: build install
 
 binary: binary-indep binary-arch
 
-.PHONY: build clean binary-indep binary-arch binary install configure
+.PHONY: patch build clean binary-indep binary-arch binary install configure